Bump numpy, scipy, matplotlib requirements to match Debian stable
Realistically, this is the platform we test on that has the oldest releases, so better to be explicit about it.
This would mean instead of:
numpy>=1.5.1 scipy>=0.9.0 matplotlib>=1.1.0 h5py>=1.3.0 sphinx_rtd_theme ipython>=2.3.0
we would declare:
numpy>=1.16 scipy>=1.1.0 matplotlib>=3.0.2 h5py>=2.8.0 sphinx_rtd_theme
I'm not actually sure that we need to declare an iPython dependency.
@aq501 - would you be happy enough with this?